Phone List POJ - 3630


Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:

  • Emergency 911

  • Alice 97 625 999

  • Bob 91 12 54 26

In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits. 

Output

For each test case, output "YES" if the list is consistent, or "NO" otherwise.

Sample Input

2 3 911 97625999 91125426 5 113 12340 123440 12345 98346

Sample Output

NO YES


#include<iostream>

#include<cstdio>

#include<cstring>

using namespace std;

const int maxn = 100000+5;

const int maxm = 100;

char op[maxn][maxm];

const int maxnd=40*10000+100;

const int maxsz=10;

inline int read()

{

    int num=0,flag=1;

    char ch;

    do{

        ch=getchar();

        if(ch=='-') flag=-1;

    }while(ch<'0'||ch>'9');

    do{

        num=num*10+ch-'0';

        ch=getchar();

    }while(ch>='0'&&ch<='9');

    return num*flag;

}

struct Trie{

  int ch[maxnd][maxsz],sz,ovo[maxnd];//,val[maxnd]

  void init()

  {

      sz=1,memset(ch[0],0,sizeof(ch[0])),memset(ovo,0,sizeof(ovo));

  }

  int id(char c) {return c-'0';}

  void insrt(char s[])

  {

      int u=0,n=strlen(s);

      for(int i=0;i<n;i++)

          {

            if(!ch[u][id(s[i])])

              ch[u][id(s[i])]=sz,memset(ch[sz],0,sizeof(ch[sz])),sz++;//,val[sz++]=0;

           u=ch[u][id(s[i])],ovo[u]++;//不要作死把这个写在for循环里面,他会多运行一次,然后就会多赋值一次,然后就会出错

          }

      //val[u]=n;

  }

  int cnt(char s[])

  {

      int u=0,n=strlen(s);

      for(int i=0;i<n;i++)

          {if(!ch[u][id(s[i])]) return false;u=ch[u][id(s[i])];}

      return ovo[u];

  }

}trie;

int main()

{

    int t=read(),n;

    while(t--)

    {

        trie.init();

        n=read();

        bool flag=0;

        for(int i=1;i<=n;i++)

            scanf("%s",op[i]),trie.insrt(op[i]);

        for(int i=1;i<=n;i++)

            if(trie.cnt(op[i])>=2) {flag=1;break;}

        if(flag) puts("NO");

        else puts("YES");

    }

    return 0;

}



评论

热度(3)